DVLA Document Checking Service
Incident Report for GOV.UK Verify
Resolved
The Document Checking Service has resumed normal operation.
Posted 4 months ago. Jun 30, 2017 - 16:54 BST
Investigating
The DVLA Document checking Service is currently down. We will update as soon as we receive progress.
Posted 4 months ago. Jun 30, 2017 - 15:34 BST
This incident affected: Document Checking Service (DVLA).