Digidentity and Post Office have an issue with verifying financial details for new sign ups
Incident Report for GOV.UK Verify
Resolved
Digidentity have made improvements to their service which should reduce any further impact of this issue on Verify users.
Posted Jun 18, 2021 - 16:20 BST
Monitoring
Digidentity made an update on 14 June 2021 and it should improve service performance. The GOV.UK Verify team is currently monitoring the service to check the need for any further changes. We'll have a further update on 17 June 2021.
Posted Jun 15, 2021 - 17:43 BST
Identified
Digidentity and Post Office have investigated this issue. A fix is expected by Tuesday 15 June 2021.
Posted Jun 14, 2021 - 14:45 BST
Update
We are continuing to investigate this issue which affects some new users. Users with a GOV.UK Verify account can continue to sign in.
Posted Jun 04, 2021 - 16:29 BST
Investigating
Digidentity and Post Office are investigating a problem with their service.

This affects some users attempting to sign up with a new GOV.UK Verify account. If users need to enter financial details because they do not have photographic ID, the chance of successfully verifying their identity is lower than normal.

No other services are impacted by this issue, and users with a GOV.UK Verify account can continue to sign in.

Regards,

GOV.UK Verify team
Posted Jun 04, 2021 - 16:28 BST
This incident affected: Certified companies / identity providers (DigIdentity, Post Office).