SecureIdentity Unavailable
Incident Report for GOV.UK Verify
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 16:44 GMT
Investigating
SecureIdentity is currently undergoing scheduled maintenance.
Posted Nov 27, 2019 - 15:48 GMT
This incident affected: GOV.UK Verify hub.