IMPORTANT: HM Land Registry is unavailable
Incident Report for GOV.UK Verify
Resolved
HM Land Registry have resolved the incident and the service is now operational
Posted Nov 26, 2022 - 10:10 GMT
Update
We are continuing to investigate this issue.
Posted Nov 25, 2022 - 17:53 GMT
Investigating
Hello,

HM Land Registry had scheduled maintenance planned on Friday 25 November, starting at 14:00 for 2 hours.

This maintenance window has overrun and HMLR are working to resolve the issues as a matter of urgency and apologise for any inconvenience caused. The entry page to their service is being kept updated with a status message: https://sign-your-mortgage-deed.landregistry.gov.uk/

No other services are impacted by this issue.

HM Land Registry is looking into this as a matter of urgency and we will update you as soon as we know more.

Regards,

Owen Blacker
Lead software engineer

GOV.UK Verify team
Posted Nov 25, 2022 - 17:32 GMT