Problem with users verifying their identity to use in NHS Total Rewards
Incident Report for GOV.UK Verify
Resolved
This incident has been resolved.
Posted May 24, 2021 - 08:18 BST
Update
We are continuing to work on a fix for this issue.
Posted May 24, 2021 - 08:17 BST
Identified
Users of NHS Total Rewards are currently unable to login to this service using their Verify identity.

We are working with NHS Total Rewards in order to fix this.
Posted Apr 30, 2021 - 10:35 BST
This incident affected: GOV.UK Verify.