Identity providers are very busy
Incident Report for GOV.UK Verify
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2020 - 17:56 GMT
Identified
Our identity providers have implemented a queuing system, and you may have to wait at certain times before you can continue. We're sorry for the delay and we're working hard to make sure everyone can get an identity account as soon as possible.
Posted Mar 26, 2020 - 17:55 GMT
Update
Due to high levels of demand, Verify's identity providers may not be able to process your application right away.
Posted Mar 23, 2020 - 13:58 GMT
Update
We are continuing to investigate this issue.
Posted Mar 23, 2020 - 11:44 GMT
Investigating
Due to high levels of demand, Verify's identity providers may not be able to process your application at this time. Please try again later.
Posted Mar 23, 2020 - 11:20 GMT
This incident affects: GOV.UK Verify hub.