Issue with NHS Total Reward Statements using Verify
Incident Report for GOV.UK Verify
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 17:57 BST
Update
This issue is resolved now.
Posted Jun 14, 2022 - 17:55 BST
Investigating
We are aware of an ongoing issue where users are unable to access NHS Total Rewards Statements and are currently investigating.
We will update when we have further information.
Posted May 26, 2022 - 11:42 BST
This incident affected: GOV.UK Verify.